Harley Riders USA Forums
Home | About Us | Contact Us
Quick Member Login:
Forgot password?


Available T-Shirt Sizes
Forum Sponsors:
Forum Statistics:
Forum Members: 5,101
Total Threads: 8,396
Total Posts: 189,195


There are 143 users
currently browsing forums.
Forum Sponsors:
You don't appear to be registered. Click here to register
Search the forums:


Harley Riders USA Forums » Harley Davidson Motorcycle Models » Dyna Glide » Rear light problem


Dyna Glide Super Glide, Super Glide Sport, Super Glide Custom, Low Rider, Street Bob, Fat Bob and Wide Glide.



Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-24-2018, 01:41 PM Top   #1 (permalink)
Junior Member
 
Join Date: Sep 2018
Member: 5225
Location: Washington
Posts: 1
Blue22 is infamous around these parts
Unhappy Rear light problem

Hello All -- My hubby and I are new to this forum, and we're hitting the ground running, searching for some troubleshooting help.

Recently got our 2006 Low Rider back from the shop (to fix a seal at the back of the primary) and by coincidence, or maybe not, now the left brake/running light doesn't work -- yet the blinker portion of it works fine.

We've checked the bulb, it's fine. We've checked all fuses, they're fine. We checked the wiring as best we could at least near where it plugs into the center rear running/brake light, and did find a spot that looked like it could be rubbing raw, so we taped that up. Problem still remains.

Another element to this mystery is before we took at look at the end of the wiring, it was making a really odd whining noise (electrical arcing) sound when we would activate the left blinker. After taping up the wires, that went away, but still only the blinker works, not the running light nor brake light. This is all regarding only the rear left signal/light. The right side and fronts are fine.

Does this sound like a relay to anyone? Any other ideas?

Thanks in advance!
S & J
Blue22 is offline   Reply With Quote
""


Old 09-25-2018, 01:27 AM Top   #2 (permalink)
Super Moderator
T-SHIRT BUYER!
HDRUSA CONTRIBUTOR
 
Chris & Carrie's Avatar
 
Join Date: Jan 2014
Member: 3392
Location: Perth ,Western Australia
Posts: 1,249
Chris & Carrie has a little shameless behaviour in the pastChris & Carrie has a little shameless behaviour in the past
Default

G'day and welcome along for the ride I'm thinking there's probably been and earth that has gotten itself fried Get yourself a test light , and start hunting for live wires by earthing the test light out and put the the other end of it to live on the rear light , if it glows then you'll know the earth to the light is rooted, try the same with the indicator. Just remember with indicator's , they can be a bit tricky 'cause sometimes they work, sometimes they don't , they work then don't, then work again
__________________
If I die riding at least i'll die free
Chris & Carrie is offline   Reply With Quote
""
Old 09-25-2018, 05:20 AM Top   #3 (permalink)
Road Seeker
 
Black Harleys Matter's Avatar
 
Join Date: Jun 2016
Member: 4441
Location: Tennessee
Posts: 70
Black Harleys Matter is infamous around these parts
Default

Welcome to the Board Blue22, feel for you with electrical problems, they are sometimes a bitch. Sometimes it can be the simple things. Chris has helped plenty of our Board Members fix problems, so I would trust what he says. Good Luck
Black Harleys Matter is offline   Reply With Quote
""
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 04:08 PM.
Powered by: vBulletin, Copyright ©2000 - 2012, Jelsoft Enterprises Limited.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2

HDRidersUSA.com and HarleyRidersUSA.com are not affiliated with or endorsed by Harley Davidson, Inc.